On Tue, Nov 01, 2011 at 02:43:49PM +0100, Antonio Quartulli wrote:
On Mon, Oct 31, 2011 at 01:42:01AM +0100, Simon
I don't quite understand what this patch is good for - it generalises the function,
but does not use the function at another point. So what it is good for (next to
add more complexity to batman ;] ).
Furthermore it counts the changes and adds it to num_local_tt, is there a bug fix
hidden in this patch somewhere? :)
No hidden bug-fix here :)
This patch aims to generalise the tt_local_reset_flags() function only. As I
discussed with Sven on IRC, this function could be quite confusing, because its
name suggests that it can be used either for other purposes, but this is not
true: it can only be used as it is now in the code.
Therefore this patch wants to generalise it enough in order to be eventually
The increment of tt_local_num is actually done inside the function and it is
useful only for the use case proposed in the current code. To generalise the
function I had to move the increment outside (somebody else could want to flip a
certain flag without affecting the local counter :-) ).
Ah okay, I missed that it was already done within the function previously - sorry,
my fault. No hidden bug fix :D
IMHO this patch is not strictly needed, but it would clean the code up (Until
it doesn't add any complexity :P)
I think thats okay. I reviewed it a second time and it does what its supposed to
do as far as i can tell.
The only thing I found a little bit confusing was the variable name
as it turns out it is only a switch (0 - switch all flags from the flags variable
off, 1 - switch these flags on). But maybe thats just me. ;)
Acked-by: Simon Wunderlich <siwu(a)hrz.tu-chemnitz.de>