Hello again nice folks,
I updated today another segment of the network with just 4 nodes, to
batman-adv 2012.2 (the one i compiled yesterday with simon patches for
blaII, marek stability fixes, and debug log enabled , yikes!)
and i couldn't get batman to work over wired ethernet?? (?)
P -(50mts wlan)- D -----(ubnt transparent bridge) 2km -- C
\----eth-------------------/
Node P and D connected by ethernet on eth0 but close enough that could
also see each other through adhoc wlan, with bla enabled, correctly
preferred ethernet connection to communicate between them (iperf
yielded 92mbps), so far so good.
now, node D and C, too far away from each other to communicate over
wlan, but connected by a "loooong eth cable" (mediated by a wds
transparent bridge) wouldn't find each other batman originator.
C originator table was empty, and D only showed P.
I thought the transparent bridge was misbehaving, so I tried in a
simpler setup using P and D, with the wifi off:
but after disabling wlan0 (batctl if del wlan0-2) and adding eth0
(batctl if add eth0) on both nodes, batman could not see each other
anymore :(
i thought i was doing something wrong, so i tried in different ways,
but could not get it to work.
batctl td eth0 shows both outgoing OGMs from local , and incoming OGMs
from remote,
but batctl l only reported outgoing OGMs.
http://pastebin.com/7DDUaXu1
diego is local node ("D"), palmeras is on the other side of the
ethernet cable ("P") (and jure is further away, connected to palmeras
by adhoc wlan, not illustrated in the previous ascii art)
i hope i'm overlooking something really obvious?
Have a nice weekend!
Gui
Hi!
Ubiquiti provides OpenWrt based SDK for their firmware. To my
information, it contains some proprietary madwifi-based WiFi drivers
with some older OpenWrt version. My question is how it would be
possible to run Batman on top of their firmware (thus not latest
OpenWrt). As Batman is in kernel, is is enough kernel-backwards
compatible to be able to run also on older (2.6) kernel versions? For
olsrd it is much simpler: you just install olsrd package and this is
it.
Mitar
(which roughly translates as "batman gone nuts?")
Hey great devs!
we've been having a particular issue in deltalibre and quintanalibre
(local WCN) with batman-adv, but so far we haven't found a precise way
to reproduce it.
The symptom is that (after some reboots or physical displacements?)
one batman-adv host becomes unreachable on layer3, although it is seen
on originators table, and can be batctl ping'ed or batctl tracerout'ed
with no problem whatsoever.
Even more, it not unreachable from the whole network, but instead from
just a few other nodes. So, let's say that the nearer nodes can layer3
ping it , but some others farther away cannot (although i can't assure
it depends on the hop distance)
All of them can batctl ping it (layer2)
A hard reboot of all the nodes solves it, connectivity is restored in
all directions.
Thing is, I've just came across it again, and managed to do some tests
to aid in description / debugging
As an aid in understanding network topology,
I'm attaching the wonderful output of "batctl vd dot |grep -v TT" for
your viewing delight
problem node is ana
it can be reached from ruth and hquilla (direct neighbours)
but arping behaves erratically from colmena or charly
and normal ping (v4 or v6) doesn't receive any reply at all when run
from colmena or charly
I used arping, with and without -b , and seemed like i could narrow
the problem down to incoming broadcast packet handling, but further
tests just left me more puzzled!
all nodes are tl-mr3220 running openwrt trunk r31316 with batman-adv
2012.2.0 , driver ath9k
secondary interfaces named _wlan1 are all tl-wn722n which uses driver ath9k_htc
nodes are around 100meters (+/-50mts) apart from each other
this behaviour has been observed (but not reported) in dissimilar
setups, using ubnt bullet2 mixed with mr3220, running r29936 with
batman-adv 2011.4.0 , with nodes 1 or 2km apart from each other.
Tests are the combined crude output of batctl td and arping, so to
make this email ease on the eye, i'm publishing them elsewhere:
http://pastebin.com/6PPwN3PS
The live openwrt configuration can be analysed in detail at
https://bitbucket.org/guidoi/deltalibre-configs/src
(it's a free, open network after all! :D )
in particular:
ana -> https://bitbucket.org/guidoi/deltalibre-configs/src/6de4ce970fe2/mac/54_E6_…
hquilla -> https://bitbucket.org/guidoi/deltalibre-configs/src/6de4ce970fe2/mac/54_E6_…
colmena -> https://bitbucket.org/guidoi/deltalibre-configs/src/6de4ce970fe2/mac/54_E6_…
Thanks a lot for the attention,
Hope that you are having fun, and that I'm not spoiling it :)
Cheers!
Gui
Hi all
I`m working on a academic develop project for improve the networks in
rural areas in Peru. We are doing some test with 6 Nanostation M5 for
create a mesh network.
I tried Commotion software with OLSR and all was Ok. Now, we are
testing BATMAN, with OpenWRT and batman-adv module, but I have some
problems.
I have compiled OpenWrt Backfire r32751 (Load: 0.09 0.10 0.05) and
installed batman-adv with opkg following this
http://wiki.openwrt.org/inbox/mesh.batman
When I put:
lsmod | grep batman
I get
batman_adv 67936 0
and seems to be load in the kernel
But when I try to add the interface wlan0 for activate batman in it,
the Nanostation remains locked and i need to reboot.
I have tried this with:
echo bat0 > /sys/class/net/wlan0/batman_adv/mesh_iface
and
batctl if add wlan0
with the same bad result.
What am i doing wrong?
That are my configuration files:
root@OpenWrt:~# cat /etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#config interface wan
# option ifname eth1
# option proto dhcp
config interface wan
option ifname eth1
option proto static
option ipaddr "my ip public for internet access"
option netmask 255.255.255.192
option gateway "my ip public gateway"
option dns 8.8.8.8
----------------------------------------
root@OpenWrt:~# cat /etc/config/wireless
config 'wifi-device' 'radio0'
option 'type' 'mac80211'
option 'macaddr' '00:27:22:52:71:a7'
option 'hwmode' '11na'
option 'htmode' 'HT20'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'TX-STBC'
list 'ht_capab' 'RX-STBC1'
list 'ht_capab' 'DSSS_CCK-40'
option 'channel' '161'
option 'txpower' '0'
option 'country' 'US'
config 'wifi-iface'
option 'device' 'radio0'
option 'network' 'lan'
option 'ssid' 'OpenWrt'
option 'encryption' 'none'
option 'mode' 'adhoc'
option 'bssid' '00:27:22:52:71:A7'
---------------------------------------------------
root@OpenWrt:~# iwconfig
lo no wireless extensions.
eth0 no wireless extensions.
eth1 no wireless extensions.
br-lan no wireless extensions.
wlan0 IEEE 802.11an ESSID:"OpenWrt"
Mode:Ad-Hoc Frequency:5.805 GHz Cell: 00:27:22:52:71:A7
Tx-Power=3 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
-----------------------------------------------------
root@OpenWrt:~# ifconfig
br-lan Link encap:Ethernet HWaddr 00:27:22:53:71:A7
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9489 errors:0 dropped:0 overruns:0 frame:0
TX packets:9584 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:989861 (966.6 KiB) TX bytes:3510637 (3.3 MiB)
eth0 Link encap:Ethernet HWaddr 00:27:22:53:71:A7
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9511 errors:0 dropped:0 overruns:0 frame:0
TX packets:9597 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1124441 (1.0 MiB) TX bytes:3512820 (3.3 MiB)
Interrupt:4
eth1 Link encap:Ethernet HWaddr 00:27:22:53:71:A8
inet addr:"my ip public" Bcast:"my ip broadcast broadcast"
Mask:255.255.255.192
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13086 errors:0 dropped:0 overruns:0 frame:0
TX packets:4552 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4041054 (3.8 MiB) TX bytes:797392 (778.7 KiB)
Interrupt:5
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1556 (1.5 KiB) TX bytes:1556 (1.5 KiB)
wlan0 Link encap:Ethernet HWaddr 00:27:22:52:71:A7
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:32
RX bytes:0 (0.0 B) TX bytes:1526 (1.4 KiB)
------------------------
I have noticed that i have not the bat0 interface created,is it normal?
Do i need create another aditional interface like ath0?
I have been following that manuals:
http://pizza.hskflashcards.com/index.php?page=B.A.T.M.A.N.+Advanced+on+Open…http://www.open-mesh.org/projects/batman-adv/wiki/Quick-start-guide
Any help o comment?
Do you recomend me to change to batmand instead?
Do you know if there is any BATMAN implementation for a mesh network
of Nanostation M5, easier to install and manipulate?
Thanks
--
Esteban
Hi,
maybe some of you have seen that I talked in the channel to Antonio whether we
should migrate to a different solution to serve our git repositories. This is
(in my opinion) a good idea because gitosis [1] (the software that we are
currently using) isn't maintained anymore and will be dropped [2] in the next
version of Debian. My preferred replacement is gitolite [3].
I already talked with Simon and discussed what side effect this could have.
Maybe side effects is not the correct word to describe it... lets call it
options. Gitolite allows to define access rights for refs. For people that are
not familiar with the storage in git: You can for example say that people can
only commit to branches with a specific prefix.
Just to give an example. We want that only the release team can create tags ->
refs/tags/ is only marked for the release team as read-write. Now we have more
interesting features like ordex is only allowed to write in branches starting
with ordex/ -> refs/heads/ordex/ is marked as rw for ordex.
Now the question is: Do we want to use this feature or not. We had following
ideas:
1. 1 repository per project
use only one repo for each project (batman-adv, batctl, batmand, ...) and
use branch namespaces for individual users:
* master, next, maint for the main stuff
* ordex/ (for example ordex/dat), hundeboll/, ... for users
* tags only for release team
2. 2 repositories per project
use one official repo for each project (batman-adv, batctl, batmand, ...)
and one for other people
* master, next, maint in both repos (synced from the main one)
* ordex/ (for example ordex/dat), hundeboll/, ... for users in the second
repo
* tags in both repositories allowed (but in the second repo only with
user prefix)
3. 1+x repositories per project
Keep everything like now
* master, next, maint for the main stuff
* each user has his own copy of the main repo in his user folder
* tags can freely commit in his own repo
Special repositories with big differences like linux-merge are kept in a
special repository.
Any other suggestions? Do you prefer any idea? Please also add other ideas
like "user folder names for idea 3 have to start with a ~ and non-user folder
names have to start with a +".
Kind regards,
Sven
[1] https://github.com/tv42/gitosis
[2] http://packages.qa.debian.org/g/gitosis/news/20110909T215628Z.html
[3] https://github.com/sitaramc/gitolite