Hi Jakub, hi David,
this time we only have one patch in the pull request of batman-adv to go into net-next.
Please pull or let me know of any problem!
Thank you, Simon
The following changes since commit 25d81f9307ffc166427d93152498f45178f5936a:
batman-adv: Fix names for kernel-doc blocks (2021-02-06 09:22:45 +0100)
are available in the Git repository at:
git://git.open-mesh.org/linux-merge.git tags/batadv-next-pullrequest-20210312
for you to fetch changes up to b1de0f01b0115575982cf24c88b35106449e9aa7:
batman-adv: Use netif_rx_any_context(). (2021-02-13 18:08:40 +0100)
---------------------------------------------------------------- There is only a single patch this time:
- Use netif_rx_any_context(), by Sebastian Andrzej Siewior
---------------------------------------------------------------- Sebastian Andrzej Siewior (1): batman-adv: Use netif_rx_any_context().
net/batman-adv/bridge_loop_avoidance.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)
From: Sebastian Andrzej Siewior bigeasy@linutronix.de
The usage of in_interrupt() in non-core code is phased out. Ideally the information of the calling context should be passed by the callers or the functions be split as appropriate.
The attempt to consolidate the code by passing an arguemnt or by distangling it failed due lack of knowledge about this driver and because the call chains are hard to follow.
As a stop gap use netif_rx_any_context() which invokes the correct code path depending on context and confines the in_interrupt() usage to core code.
Signed-off-by: Sebastian Andrzej Siewior bigeasy@linutronix.de Signed-off-by: Sven Eckelmann sven@narfation.org Signed-off-by: Simon Wunderlich sw@simonwunderlich.de --- net/batman-adv/bridge_loop_avoidance.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/net/batman-adv/bridge_loop_avoidance.c b/net/batman-adv/bridge_loop_avoidance.c index 360bdbf44748..bcd543ce835b 100644 --- a/net/batman-adv/bridge_loop_avoidance.c +++ b/net/batman-adv/bridge_loop_avoidance.c @@ -438,10 +438,7 @@ static void batadv_bla_send_claim(struct batadv_priv *bat_priv, u8 *mac, batadv_add_counter(bat_priv, BATADV_CNT_RX_BYTES, skb->len + ETH_HLEN);
- if (in_interrupt()) - netif_rx(skb); - else - netif_rx_ni(skb); + netif_rx_any_context(skb); out: if (primary_if) batadv_hardif_put(primary_if);
Hello:
This patch was applied to netdev/net-next.git (refs/heads/master):
On Fri, 12 Mar 2021 16:47:24 +0100 you wrote:
From: Sebastian Andrzej Siewior bigeasy@linutronix.de
The usage of in_interrupt() in non-core code is phased out. Ideally the information of the calling context should be passed by the callers or the functions be split as appropriate.
The attempt to consolidate the code by passing an arguemnt or by distangling it failed due lack of knowledge about this driver and because the call chains are hard to follow.
[...]
Here is the summary with links: - [1/1] batman-adv: Use netif_rx_any_context(). https://git.kernel.org/netdev/net-next/c/b1de0f01b011
You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html
b.a.t.m.a.n@lists.open-mesh.org