Hi Sven,
On Sat, May 04, 2024 at 11:35:38AM +0200, Sven Eckelmann wrote:
On Wednesday, 1 May 2024 17:02:42 CEST Erick Archer wrote:
diff --git a/include/uapi/linux/batadv_packet.h b/include/uapi/linux/batadv_packet.h index 6e25753015df..dfbe30536995 100644 --- a/include/uapi/linux/batadv_packet.h +++ b/include/uapi/linux/batadv_packet.h
[...]
+/**
- struct batadv_tvlv_tt_data - tt data propagated through the tt tvlv container
- @flags: translation table flags (see batadv_tt_data_flags)
- @ttvn: translation table version number
- @num_vlan: number of announced VLANs. In the TVLV this struct is followed by
- one batadv_tvlv_tt_vlan_data object per announced vlan
- @vlan_data: array of batadv_tvlv_tt_vlan_data objects
- */
+struct batadv_tvlv_tt_data {
__u8 flags;
__u8 ttvn;
__be16 num_vlan;
struct batadv_tvlv_tt_vlan_data vlan_data[] __counted_by_be(num_vlan);
+};
Thanks for the updates. But I can't accept this at the moment because __counted_by_be is used in an uapi header without it being defined include/uapi/linux/stddef.h (and this file is also not included in this header).
See commit c8248faf3ca2 ("Compiler Attributes: counted_by: Adjust name and identifier expansion") as an example for the similar __counted_by macro.
If I understand correctly, the following changes are also needed because the annotated struct is defined in a "uapi" header. Sorry if it's a stupid question, but I'm new to these topics.
diff --git a/include/uapi/linux/batadv_packet.h b/include/uapi/linux/batadv_packet.h index 6e25753015df..41f39d7661c9 100644 --- a/include/uapi/linux/batadv_packet.h +++ b/include/uapi/linux/batadv_packet.h @@ -9,6 +9,7 @@
#include <asm/byteorder.h> #include <linux/if_ether.h> +#include <linux/stddef.h> #include <linux/types.h>
/** diff --git a/include/uapi/linux/stddef.h b/include/uapi/linux/stddef.h index 2ec6f35cda32..58154117d9b0 100644 --- a/include/uapi/linux/stddef.h +++ b/include/uapi/linux/stddef.h @@ -55,4 +55,12 @@ #define __counted_by(m) #endif
+#ifndef __counted_by_le +#define __counted_by_le(m) +#endif + +#ifndef __counted_by_be +#define __counted_by_be(m) +#endif + #endif /* _UAPI_LINUX_STDDEF_H */
If this is the right path, can these changes be merged into a single patch or is it better to add a previous patch to define __counted_by{le,be}?
Regards, Erick
Kind regards, Sven