On 2012-02-07 12:10, Marek Lindner wrote:
- unsigned long random_seqno;
- /* randomize initial seqno to avoid collision */
- get_random_bytes(&random_seqno, sizeof(unsigned long));
- atomic_set(&hard_iface->seqno, (uint32_t)random_seqno);
Wouldn't it be better to cast "unsigned long" in the call to atomic_set()?
Why should it better ?
Maybe not better, but at least it is consistent with the type of random_seqno, which is unsigned long. I know the two types are identical, but nevertheless, I like to use the same type of type :)