On Monday, 31 December 2018 12.09.50 CET Linus Lüssing wrote: [...]
[...]
#ifdef CONFIG_BATMAN_ADV_BLA if (nla_put_u16(msg, BATADV_ATTR_BLA_CRC, ntohs(bat_priv->bla.claim_dest.group)))
goto out;
goto nla_put_failure;
#endif
if (batadv_mcast_mesh_info_put(msg, bat_priv))
goto out;
goto nla_put_failure;
With the rename of "batadv_netlink_mesh_info_put" to "batadv_netlink_mesh_put", I'm wondering whether batadv_mcast_mesh_info_put() should be renamed, too. batadv_mcast_mesh_put() would probably be a bit too generic. But maybe something like batadv_mcast_nl_mesh_put()?
Not relevant for this patch. But feel free to check what we can do to make it more consistent. We can then do it after having the rest in place.
Kind regards, Sven