On Wednesday 13 November 2013 19:14:47 Simon Wunderlich wrote:
From: Simon Wunderlich simon@open-mesh.com
For the network wide multi interface optimization there are different routers for each outgoing interface (outgoing from the OGM perspective, incoming for payload traffic). To reflect this, change the router and associated data to a list of routers.
While at it, rename batadv_orig_node_get_router() to batadv_orig_router_get() to follow the new naming scheme.
Signed-off-by: Simon Wunderlich simon@open-mesh.com
Changes to PATCHv2:
- keep tvlv_ogm_receive() at its original place (Linus)
- only forward OGMs for the default interface (check removed in the next patch) (Linus)
- add forgotten rcu_read_lock in _batadv_update_route() (Linus)
- add/repair kerneldoc and comments for batadv_purge_orig_ifinfo() and batadv_purge_orig_node() (Linus)
- rename if_received -> if_outgoing (Linus)
- fix kerneldoc (Linus)
- various other style issues
Changes to PATCH:
- change orig_ifinfo locking from implicit rcu style to refcount locking
- pass skb instead of buffers to the OGM processing functions
- remove unused tt_buff pointer from some bat_iv functions
- rename batadv_orig_node_ifinfo* to batadv_orig_ifinfo* - name is still long enough
- rename batadv_orig_node_get_router to batadv_orig_router_get
- rename batadv_orig_node_get_ifinfo to batadv_orig_ifinfo_get
Changes to RFCv2:
- various style changes
- remove unneccesary batadv_orig_node_set_router prototype
Changes to RFC:
- rebase on current master
- remove useless goto
- split out batman_seqno_reset as well to avoid false seqno window protections
bat_iv_ogm.c | 452 ++++++++++++++++++++++++++++------------------- distributed-arp-table.c | 3 +- gateway_client.c | 11 +- icmp_socket.c | 3 +- network-coding.c | 9 +- originator.c | 242 ++++++++++++++++++++++++- originator.h | 12 +- routing.c | 38 +++- routing.h | 1 + translation-table.c | 3 +- types.h | 32 +++- 11 files changed, 590 insertions(+), 216 deletions(-)
Applied in revision de6bcc7.
Thanks, Marek