Linus Lüssing wrote:
This makes exposing bat_priv's atomic_ts storing boolean or uint values possible with only two additional lines of code in the future. It also further reduces the amount of duplicate code in bat_sysfs.c.
Signed-off-by: Linus Lüssing linus.luessing@web.de
Please fix the checkpatch problems first:
WARNING: please, no space before tabs #47: FILE: batman-adv/bat_sysfs.c:55: +ssize_t show_##_name(struct kobject *kobj, struct attribute *attr, ^I$
WARNING: storage class should be at the beginning of the declaration #101: FILE: batman-adv/bat_sysfs.c:139: +inline static ssize_t __store_bool_attr(char *buff, size_t count,
ERROR: inline keyword should sit between storage class and type #101: FILE: batman-adv/bat_sysfs.c:139: +inline static ssize_t __store_bool_attr(char *buff, size_t count,
WARNING: storage class should be at the beginning of the declaration #126: FILE: batman-adv/bat_sysfs.c:191: +inline static ssize_t __store_uint_attr(char *buff, size_t count,
ERROR: inline keyword should sit between storage class and type #126: FILE: batman-adv/bat_sysfs.c:191: +inline static ssize_t __store_uint_attr(char *buff, size_t count,
total: 2 errors, 3 warnings, 0 checks, 241 lines checked
0003-batman-adv-Introduce-generic-BAT_ATTR_-macros.patch has style problems, please review. If any of these errors are false positives report them to the maintainer, see CHECKPATCH in MAINTAINERS.