The annotated tag, batman-adv-for-davem has been created at 81977c9ec396b4a53f044e82a3fde6ed41e38b5d (tag) tagging dea8db91bac33f3a63adc8956a7b87c440d866b8 (commit) replaces v3.4-rc1 tagged by Antonio Quartulli on Wed Apr 11 14:33:32 2012 +0200
- Shortlog ------------------------------------------------------------ Included changes: * add my name to the maintainers list of batman-adv * some clean up fixes * increases the default hop-penalty in order to encourage the routing protocol to choose shorter routes * renew the bridge loop avoidance mechanism
The latter mechanism was already present in batman-adv but recently the concept has been discussed again and here comes the new implementation. Moreover we added a compile option in order to let expert people, which think that this mechanism is not helpful at all, disable it and save some space.
Antonio Quartulli (13): batman-adv: clean up Kconfig batman-adv: use ETH_ALEN instead of hardcoded numeric constants batman-adv: add biggest_unsigned_int(x) macro batman-adv: use ETH_HLEN instead of sizeof(struct ethhdr) batman-adv: print OGM seq numbers as unsigned long batman-adv: skip the window protection test when the originator has no neighbours batman-adv: add UNICAST_4ADDR packet type batman-adv: add a new log level for DAT debugging batman-adv: Distributed ARP Table - create DHT helper functions batman-adv: Distributed ARP Table - add ARP parsing functions batman-adv: Distributed ARP Table - add snooping functions for ARP messages batman-adv: Distributed ARP Table - increase default soft_iface ARP table timeout batman-adv: Distributed ARP Table - add compile option
Marek Lindner (9): batman-adv: encourage batman to take shorter routes by changing the default hop penalty batman-adv: move ogm initialization into the proper function batman-adv: refactoring API: find generalized name for bat_ogm_init callback batman-adv: randomize initial seqno to avoid collision batman-adv: add iface_disable() callback to routing API batman-adv: handle routing code initialization properly batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN batman-adv: mark existing ogm variables as batman iv
Simon Wunderlich (10): batman-adv: remove old bridge loop avoidance code batman-adv: add basic bridge loop avoidance code batman-adv: make bridge loop avoidance switchable batman-adv: export claim tables through debugfs batman-adv: allow multiple entries in tt_global_entries batman-adv: don't let backbone gateways exchange tt entries batman-adv: add broadcast duplicate check batman-adv: drop STP over batman batman-adv: form groups in the bridge loop avoidance batman-adv: add bridge loop avoidance compile option
Sven Eckelmann (2): batman-adv: Replace bitarray operations with bitmap batman-adv: Remove declaration of only locally used functions
-----------------------------------------------------------------------