The annotated tag, v2012.2.0 has been created at aa62bdc20010a94a9c8c840c8f57a0431c224e9a (tag) tagging b82d11e243ec144c515e7d04e8e8c31b111a060d (commit) replaces v2012.1.0 tagged by Sven Eckelmann on Tue Jun 12 18:26:55 2012 +0200
- Shortlog ------------------------------------------------------------ batman-adv 2012.2.0
Antonio Quartulli (33): batman-adv: use ETH_ALEN instead of hardcoded numeric constants batman-adv: add biggest_unsigned_int(x) macro batman-adv: use ETH_HLEN instead of sizeof(struct ethhdr) batman-adv: print OGM seq numbers as unsigned long batman-adv: skip the window protection test when the originator has no neighbours batman-adv: add UNICAST_4ADDR packet type batman-adv: add a new log level for DAT debugging batman-adv: Distributed ARP Table - create DHT helper functions batman-adv: Distributed ARP Table - add ARP parsing functions batman-adv: Distributed ARP Table - add snooping functions for ARP messages batman-adv: Distributed ARP Table - increase default soft_iface ARP table timeout batman-adv: Distributed ARP Table - add compile option batman-adv: fix wrong dhcp option list browsing batman-adv: remove unused variable batman-adv: update copyright years batman-adv: add contributor name batman-adv: add BAT_UNICAST_4ADDR handler in the packet-handlers array batman-adv: avoid skb_linearise() if not needed batman-adv: improve unicast packet (re)routing batman-adv: put long strings on a dedicated line batman-adv: unset the TT_CLIENT_PENDING flag if the new local entry already exists batman-adv: fix comments ending style batman-adv: use static const for STP constant address batman-adv: use static inline functions to fake not compiled-in routines batman-adv: convert the tt_crc to network order batman-adv: use static inline functions instead of foo(...) batman-adv: use uint32_t instead of unsigned long to avoid cast batman-adv: use real error codes instead of meaningless -1 batman-adv: fix comment style in DAT code batman-adv: opening function bracket must be on a new line batman-adv: use fake functions instead of defines for not compiled-in routines batman-adv: remove biggest_unsigned_int() macro batman-adv: fix comment style and typo
Danny Kukawka (1): batman-adv: use dev_hw_addr_random() instead of random_ether_addr()
Eric Dumazet (1): net: cleanup unsigned to unsigned int
Linus Luessing (1): batman-adv: Adding hard_iface specific sysfs wrapper macros for UINT
Marek Lindner (33): batman-adv: encourage batman to take shorter routes by changing the default hop penalty batman-adv: fix checkpatch complaints batman-adv: compat layer also needs ifdefs for bridge loop avoidance batman-adv: move ogm initialization into the proper function batman-adv: refactoring API: find generalized name for bat_ogm_init callback batman-adv: randomize initial seqno to avoid collision batman-adv: add iface_disable() callback to routing API batman-adv: handle routing code initialization properly batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN batman-adv: mark existing ogm variables as batman iv Merge branch 'next' Merge branch 'next' batman-adv: introduce is_single_hop_neigh variable to increase readability batman-adv: introduce packet type handler array for incoming packets batman-adv: register batman ogm receive function during protocol init batman-adv: rename last_valid to last_seen batman-adv: replace HZ calculations with jiffies_to_msecs() batman-adv: split neigh_new function into generic and batman iv specific parts Merge branch 'next' batman-adv: ignore protocol packets if the interface did not enable this protocol batman-adv: refactoring API: find generalized name for bat_ogm_update_mac callback batman-adv: rename sysfs macros to reflect the soft-interface dependency batman-adv: avoid temporary routing loops by being strict on forwarded OGMs batman-adv: prepare lq_update_lock to be shared among different protocols batman-adv: refactor window_protected to avoid unnecessary return statement batman-adv: fix checkpatch string complaint batman-adv: fix checkpatch opening parenthesis complaint Merge branch 'maint' into next batman-adv: change comment style for David batman-adv: change comment style for David batman-adv: change comment style for David batman_adv: fix namespace for neigh_node_new function
Simon Wunderlich (11): batman-adv: remove old bridge loop avoidance code batman-adv: add basic bridge loop avoidance code batman-adv: make bridge loop avoidance switchable batman-adv: export claim tables through debugfs batman-adv: allow multiple entries in tt_global_entries batman-adv: don't let backbone gateways exchange tt entries batman-adv: add broadcast duplicate check batman-adv: drop STP over batman batman-adv: form groups in the bridge loop avoidance batman-adv: add bridge loop avoidance compile option batman-adv: only bloat with bla-structures if activated
Sven Eckelmann (18): batman-adv: Replace bitarray operations with bitmap batman-adv: Remove declaration of only locally used functions batman-adv: Remove declaration of only locally used functions batman-adv: Fix daily check regression in blaII batman-adv: Remove useless branch for NET_ADDR_RANDOM batman-adv: Backport dev_hw_addr_random batman-adv: Fix indentation of multiline statements batman-adv: Ignore 80-chars per line limits for strings batman-adv: Don't begin block comments with only a /* line batman-adv: Use {} braces consistent on the arms of a statement batman-adv: Remove spaces after a cast Merge branch 'next' Merge tag 'v2012.1.0' batman-adv: Start new development cycle batman-adv: Add routing_algo to README batman-adv: Revert Distributed ARP Table batman-adv: Update compatible kernel version number batman-adv: Update CHANGELOG for upcoming release
-----------------------------------------------------------------------