The branch, ecsv/flowdissector has been created at d3be424009ba2884287fc95d888dc4f6fdf23483 (commit)
- Shortlog ------------------------------------------------------------ commit d3be424009ba2884287fc95d888dc4f6fdf23483 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Mon Nov 27 13:33:41 2017 +0100
flow_dissector: Parse batman-adv unicast headers
The batman-adv unicast packets contain a full layer 2 frame in encapsulated form. The flow dissector must therefore be able to parse the batman-adv unicast header to reach the layer 2+3 information.
+--------------------+ | ip(v6)hdr | +--------------------+ | inner ethhdr | +--------------------+ | batadv unicast hdr | +--------------------+ | outer ethhdr | +--------------------+
The obtained information from the upper layer can then be used by RPS to schedule the processing on separate cores. This allows better distribution of multiple flows from the same neighbor to different cores.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 6e57df8d6a43789132049190e6c1a363929bbef1 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:39:48 2017 +0100
batman-adv: Convert packet.h to uapi header
The header file is used by different userspace programs to inject packets or to decode sniffed packets. It should therefore be available to them as userspace header.
Also other components in the kernel (like the flow dissector) require access to the packet definitions to be able to decode ETH_P_BATMAN ethernet packets.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 7d6278a48e0449bec7b1fcf9a9c70ceea4de86ef Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:17:28 2017 +0100
batman-adv: Remove usage of BIT(x) in packet.h
The BIT(x) macro is no longer available for uapi headers because it is defined outside of it (linux/bitops.h). The use of it must therefore be avoided and replaced by an appropriate other representation.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 345e2255baa6fdcab6686f5dd39c4c2ed932d0f6 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 11:39:29 2017 +0100
batman-adv: Let packet.h include its headers directly
The headers used by packet.h should also be included by it directly. main.h is currently dealing with it in batman-adv, but this will no longer work when this header is moved to include/uapi/linux/.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit eb3ff71c60e26c64c5cf5ca844fae1dbf1655136 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:31:51 2017 +0100
batman-adv: Rename batman-adv.h to batadv_genl.h
This file contains the relevant information to let userspace communicate with batman-adv over generic netlink. The relevant genl enums for the attributes and commands have the prefix batadv_genl. Renaming this file to this name therefore represents the content better and avoids confusion with the file which will contain the packet format definitions.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 60b1a1ef22c957efb2bbb8df05d1cb051152eb7a Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:22:16 2017 +0100
batman-adv: Change nl references to genl
The batman-adv netlink functionality is actually not pure netlink but is using NETLINK_GENERIC and related API. The code should therefore also use this "genl" instead of "nl" to make this more clear.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
-----------------------------------------------------------------------