The following commit has been merged in the next branch: commit 372d1bab30e4ca6aa559f25f5f6bd8c0ae3b5cc5 Author: Marek Lindner lindner_marek@yahoo.de Date: Tue Feb 7 17:20:50 2012 +0800
batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN
Using BATMAN_OGM_LEN leaves one with the impression that this is the full packet size which is not the case. Therefore the variable is renamed.
Signed-off-by: Marek Lindner lindner_marek@yahoo.de
diff --git a/packet.h b/packet.h index db6946a..7971a69 100644 --- a/packet.h +++ b/packet.h @@ -125,7 +125,7 @@ struct batman_ogm_packet { uint16_t tt_crc; } __packed;
-#define BATMAN_OGM_LEN sizeof(struct batman_ogm_packet) +#define BATMAN_OGM_HLEN sizeof(struct batman_ogm_packet)
struct icmp_packet { struct batman_header header;