The annotated tag, batman-adv-for-davem has been created at 44f69d17bdabb80ba18fdc5be2b7223d8356bc39 (tag) tagging 676970e55b1033af7f0a03d4037b4d9b76327ded (commit) replaces v4.6-rc7 tagged by Antonio Quartulli on Tue May 10 18:39:11 2016 +0800
- Shortlog ------------------------------------------------------------ Included changes: - remove useless skb size check in batadv_interface_rx - basic netns support introduced by Andrew Lunn: - prevent virtual interface from changing netns by setting NETIF_F_NETNS_LOCAL - create virtual interface within the netns of the first hard-interface - introduce detection of complex bridge loops and report event to the user (via udev) when the Bridge Loop Avoidance mechanism can't prevent them - minor reference counting bugfixes for the hard_iface object that couldn't make it via the net tree - use kref_get() instead of kref_get_unless_zero() to make reference counting bug more visible - use batadv_compare_eth() all over the code when possible instead of plain memcmp() - minor code cleanup and style adjustments
Andrew Lunn (2): batman-adv: NETIF_F_NETNS_LOCAL feature to prevent netns moves batman-adv: Create batman soft interfaces within correct netns.
Antonio Quartulli (3): batman-adv: use static string for table headers batman-adv: fix wrong names in kerneldoc batman-adv: use batadv_compare_eth when possible
David S. Miller (2): Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net Merge tag 'batman-adv-for-davem' of git://git.open-mesh.org/linux-merge
Florian Westphal (1): treewide: replace dev->trans_start update with helper
Geliang Tang (2): batman-adv: use list_for_each_entry_safe batman-adv: use to_delayed_work
Marek Lindner (1): batman-adv: replace ethertype variable with ETH_P_BATMAN for readability
Simon Wunderlich (5): batman-adv: Start new development cycle batman-adv: fix debuginfo macro style issue batman-adv: move and restructure batadv_v_ogm_forward batman-adv: Merge batadv_v_ogm_orig_update into batadv_v_ogm_route_update batman-adv: add detection for complex bridge loops
Sven Eckelmann (17): batman-adv: Fix checkpatch warning about 'unsigned' type batman-adv: Fix kerneldoc for batadv_compare_claim batman-adv: Add kernel-doc for batadv_interface_rx batman-adv: Fix function names on new line starting with '*' batman-adv: Split batadv_iv_ogm_orig_del_if function batman-adv: Remove unused parameter recv_if of batadv_interface_rx batman-adv: Remove hdr_size skb size check in batadv_interface_rx batman-adv: Check hard_iface refcnt before calling function batman-adv: Check hard_iface refcnt when receiving skb batman-adv: Increase hard_iface refcnt for ptype batman-adv: Use kref_get for batadv_tvlv_container_get batman-adv: Use kref_get for batadv_nc_get_nc_node batman-adv: Use kref_get for batadv_gw_select batman-adv: Use kref_get for batadv_gw_node_add batman-adv: Use kref_get for hard_iface subfunctions batman-adv: Use kref_get for _batadv_update_route batman-adv: Use bool as return type for boolean functions
-----------------------------------------------------------------------