The annotated tag, v2011.2.0 has been created at 7601fec63d5ef16779e665d7949faafe0ad1c00d (tag) tagging 885c663956e419e7a72419681766d339262bb50c (commit) replaces v2011.1.0 tagged by Sven Eckelmann on Sun Jun 19 20:24:55 2011 +0200
- Shortlog ------------------------------------------------------------ batman-adv 2011.2.0
Andrew Lunn (1): batman-adv: Set the txqueuelen to zero when creating soft interface.
Antonio Quartulli (7): batman-adv: Modifing hna_local_fill_buffer() return value batman-adv: orig_node must be freed after in case of timeout batman-adv: orig_hash_find() manages rcu_lock/unlock internally batman-adv: Move definition of atomic_dec_not_zero() into main.h batman-adv: fix gw_node_update() and gw_election() batman-adv: rename everything from *hna* into *tt* (translation table) batman-adv: correct kobject_set_name() arguments
Daniele Furlan (1): batman-adv: remove duplicate code from function is_bidirectional_neigh()
David Decotigny (1): batman-adv: cosmetic: Use ethtool ethtool_cmd_speed API
Jesper Juhl (2): Even Batman should not dereference NULL pointers Batman: Remove two duplicate includes.
Linus Lüssing (14): batman-adv: Fix kernel panic when fetching vis data on a vis server batman-adv: Remove duplicate types.h inclusions batman-adv: Switch order of types.h and compat.h inclusion batman-adv: Disallow originator addressing within mesh layer batman-adv: Make bat_priv->curr_gw an rcu protected pointer batman-adv: add __rcu annotations for gw_node batman-adv: Increase orig_node refcount before releasing rcu read lock batman-adv: Fix possible buffer overflow in softif neigh list output batman-adv: Remove unused hdr_size variable in route_unicast_packet() batman-adv: Move bonding / iface alternating router search to own functions batman-adv: Make gateway_get_selected type safe batman-adv: Simplify gw_check_election(), use gw_get_selected() batman-adv: Make orig_node->router an rcu protected pointer batman-adv: Protect global TQ window with a spinlock
Lucas De Marchi (1): batman-adv: Fix common misspellings
Marek Lindner (29): batman-adv: remove hash resize functions batman-adv: protect neighbor nodes with reference counters batman-adv: convert neighbor list to hlist batman-adv: protect neighbor list with rcu locks batman-adv: adjust NULL pointer check style batman-adv: free neighbors when an interface is deactivated batman-adv: protect neigh_nodes used outside of rcu_locks with refcounting batman-adv: protect each hash row with rcu locks batman-adv: protect originator nodes with reference counters batman-adv: protect ogm counter arrays with spinlock batman-adv: remove orig_hash spinlock batman-adv: protect bit operations to count OGMs with spinlock batman-adv: make broadcast seqno operations atomic batman-adv: Correct rcu refcounting for gw_node batman-adv: Correct rcu refcounting for softif_neigh batman-adv: Correct rcu refcounting for batman_if batman-adv: Correct rcu refcounting for neigh_node batman-adv: separate ethernet comparing calls from hash functions batman-adv: remove extra layer between hash and hash element - hash bucket batman-adv: Correct rcu refcounting for orig_node batman-adv: increase refcount in create_neighbor to be consistent batman-adv: rename global if_list to hardif_list batman-adv: rename batman_if struct to hard_iface batman-adv: concentrate all curr_gw related rcu operations in select/deselect functions batman-adv: Make bat_priv->primary_if an rcu protected pointer batman-adv: remove misplaced comment batman-adv: multi vlan support for bridge loop detection batman-adv: Fix refcount imbalance in find_router batman-adv: reset broadcast flood protection on error
Michał Mirosław (2): batman-adv: remove rx_csum ethtool_ops net: batman-adv: remove rx_csum ethtool_ops
Paul E. McKenney (3): batman-adv: convert call_rcu(gw_node_free_rcu) to kfree_rcu batman-adv: convert call_rcu(neigh_node_free_rcu) to kfree() batman-adv: convert call_rcu(softif_neigh_free_rcu) to kfree_rcu
Simon Wunderlich (3): batman-adv: remove unused parameters batman-adv: protect bonding with rcu locks batman-adv: protect softif_neigh by rcu
Sven Eckelmann (46): batman-adv: Rename if_list_queue to if_queue batman-adv: Remove hash_iterate batman-adv: Use kernel facilities for bit operations batman-adv: Remove line over 80 characters batman-adv: Remove TYPE_OF_WORD define batman-adv: Use "__attribute__" shortcut macros batman-adv: Mark bucket_free_orig_rcu as static batman-adv: Silence checkpatch warnings about spinlocks batman-adv: Create roughly equal sized fragments batman-adv: Calculate correct size for merged packets batman-adv: Remove dangling declaration of hash_remove_element batman-adv: Remove unused definitions batman-adv: Remove declaration of batman_skb_recv batman-adv: Remove unused variables batman-adv: Remove vis info on hashing errors batman-adv: Remove vis info element in free_info batman-adv: Make vis info stack traversal threadsafe batman-adv: Update copyright years batman-adv: Merge batman-adv 2011.0.0 batman-adv: Linearize fragment packets before merge batman-adv: Split combined variable declarations batman-adv: Use successive sequence numbers for fragments batman-adv: else should follow close brace '}' batman-adv: Disallow regular interface as mesh device batman-adv: Remove subversion/svk revision information batman-adv: Add missing static for softif_neigh_deselect batman-adv: Fix imbalanced locking in gw_node_update Merge commit 'v2011.1.0' batman-adv: Start new development cycle Merge branch 'master' into next batman-adv: Remove unnecessary hardif_list_lock batman-adv: Avoid deadlock between rtnl_lock and s_active batman-adv: Fix rcu_lock imbalance in softif_neigh_get batman-adv: Rename bat_printk.c to compat.c batman-adv: Fix line over 80 characters batman-adv: Don't include bat_sysfs.h in compat.h batman-adv: Remove unused variable r in bat_printk batman-adv: Remove multiline comments from line ending Merge branch 'master' into next batman-adv: Fix build with linux 2.6.25-2.6.27 batman-adv: Add missing hardif_free_ref in forw_packet_free batman-adv: Add compatibility code for kfree_rcu batman-adv: Use rcu_dereference_protected by update-side batman-adv: Update README for upcoming release batman-adv: Add some initial notes in CHANGELOG for upcoming release batman-adv: update version for release
Sylvestre Ledru (1): batman-adv: fix minor typos/spelling
-----------------------------------------------------------------------