The annotated tag, batman-adv-for-davem has been updated to 0177649f776ef82b4b4ceb73d5e7b926b24e5af1 (tag) from ad1c8b0817e002e9901b44be822a90251713fadb (which is now obsolete) tagging 969e62ad00763fed9ea28700ef7a7d97fdbfddf3 (commit) replaces v3.4-rc4 tagged by Antonio Quartulli on Tue May 1 09:49:12 2012 +0200
- Shortlog ------------------------------------------------------------ Included changes:
* minor fixes and cleanups * minor routing protocol API cleanups
Antonio Quartulli (8): batman-adv: clean up Kconfig batman-adv: use ETH_ALEN instead of hardcoded numeric constants batman-adv: convert the tt_crc to network order batman-adv: remove duplicated line in comment batman-adv: use ETH_HLEN instead of sizeof(struct ethhdr) batman-adv: print OGM seq numbers as unsigned int batman-adv: skip the window protection test when the originator has no neighbours batman-adv: fix wrong dhcp option list browsing
Eric Dumazet (1): net: cleanup unsigned to unsigned int
Marek Lindner (15): batman-adv: encourage batman to take shorter routes by changing the default hop penalty batman-adv: move ogm initialization into the proper function batman-adv: refactoring API: find generalized name for bat_ogm_init callback batman-adv: randomize initial seqno to avoid collision batman-adv: add iface_disable() callback to routing API batman-adv: handle routing code initialization properly batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN batman-adv: mark existing ogm variables as batman iv batman-adv: introduce is_single_hop_neigh variable to increase readability batman-adv: introduce packet type handler array for incoming packets batman-adv: register batman ogm receive function during protocol init batman-adv: rename last_valid to last_seen batman-adv: replace HZ calculations with jiffies_to_msecs() batman-adv: split neigh_new function into generic and batman iv specific parts
Simon Wunderlich (10): batman-adv: remove old bridge loop avoidance code batman-adv: add basic bridge loop avoidance code batman-adv: make bridge loop avoidance switchable batman-adv: export claim tables through debugfs batman-adv: allow multiple entries in tt_global_entries batman-adv: don't let backbone gateways exchange tt entries batman-adv: add broadcast duplicate check batman-adv: drop STP over batman batman-adv: form groups in the bridge loop avoidance batman-adv: add bridge loop avoidance compile option
Sven Eckelmann (2): batman-adv: Replace bitarray operations with bitmap batman-adv: Remove declaration of only locally used functions
-----------------------------------------------------------------------