The annotated tag, batadv-next-for-davem-20161027 has been created at ecab595920a0fdd8f132dd2286dbd5b53ff2a333 (tag) tagging 4c7da0f6dbcde2431d773ce03cde5e7abede54e0 (commit) replaces v4.8 tagged by Simon Wunderlich on Thu Oct 27 20:56:37 2016 +0200
- Shortlog ------------------------------------------------------------ This code cleanup patchset includes the following changes (chronological order):
- bump version strings, by Simon Wunderlich
- README updates/clean up, by Sven Eckelmann (4 patches)
- Code clean up and restructuring by Sven Eckelmann (2 patches)
- Kerneldoc fix in forw_packet structure, by Linus Luessing
- Remove unused argument in dbg_arp, by Antonio Quartulli
- Add support to build batman-adv without wireless, by Linus Luessing
- Restructure error handling for is_ap_isolated, by Markus Elfring
- Remove unused initialization in various functions, by Sven Eckelmann
- Use better names for fragment and gateway list heads, by Sven Eckelmann (2 patches)
- Convert to octal permissions for files, by Sven Eckelmann
- Avoid precedence issues for some macros, by Sven Eckelmann
Andrew Lunn (5): batman-adv: Handle parent interfaces in a different netns batman-adv: Suppress debugfs entries for netns's batman-adv: add B.A.T.M.A.N. IV bat_gw_dump implementations batman-adv: add B.A.T.M.A.N. Dump BLA claims via netlink batman-adv: Indicate netlink socket can be used with netns.
Antonio Quartulli (5): batman-adv: make the GW selection class algorithm specific batman-adv: make GW election code protocol specific batman-adv: B.A.T.M.A.N. V - implement GW selection logic batman-adv: disable sysfs knobs when GW-mode is not implemented batman-adv: remove unsed argument from batadv_dbg_arp() function
David S. Miller (1): Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net
Linus Lüssing (5): batman-adv: Remove unused primary_if and bat_priv variables batman-adv: Introduce forward packet creation helper batman-adv: Use bitwise instead of arithmetic operator for flags batman-adv: fix batadv_forw_packet kerneldoc for list attribute batman-adv: Allow selecting BATMAN V if CFG80211 is not built
Markus Elfring (1): batman-adv: Less function calls in batadv_is_ap_isolated() after error detection
Markus Pargmann (1): batman-adv: iv_ogm, Reduce code duplication
Masahiro Yamada (1): treewide: remove redundant #include <linux/kconfig.h>
Matthias Schiffer (6): batman-adv: netlink: add routing_algo query batman-adv: netlink: hardif query batman-adv: netlink: add translation table query batman-adv: netlink: add originator and neighbor table queries batman-adv: add B.A.T.M.A.N. IV bat_{orig, neigh}_dump implementations batman-adv: add B.A.T.M.A.N. V bat_{orig, neigh}_dump implementations
Simon Wunderlich (3): batman-adv: Start new development cycle batman-adv: add backbone table netlink support batman-adv: Start new development cycle
Sven Eckelmann (40): batman-adv: Document optional batadv_algo_ops batman-adv: Define module rtnl link name batman-adv: Modify mesh_iface outside sysfs context batman-adv: Revert "postpone sysfs removal when unregistering" batman-adv: Avoid sysfs name collision for netns moves batman-adv: use kmem_cache for translation table batman-adv: Remove orig_node reference handling from send_skb_unicast batman-adv: Fix consistency of update route messages batman-adv: Provide TTVN in the mesh_info netlink msg batman-adv: netlink: add gateway table queries batman-adv: add B.A.T.M.A.N. V bat_gw_dump implementations batman-adv: Provide bla group in the mesh_info netlink msg batman-adv: Place kref_get for orig_node_vlan near use batman-adv: Place kref_get for orig_ifinfo near use batman-adv: Place kref_get for tt_orig_list_entry near use batman-adv: Place kref_get for neigh_ifinfo near use batman-adv: Place kref_get for neigh_node near use batman-adv: Place kref_get for orig_node near use batman-adv: Place kref_get for tt_local_entry near use batman-adv: Place kref_get for tt_common near use batman-adv: Place kref_get for bla_claim near use batman-adv: Place kref_get for bla_backbone_gw near use batman-adv: Place kref_get for dat_entry near use batman-adv: Place kref_get for gw_node near use batman-adv: Place kref_get for hard_iface near use batman-adv: Place kref_get for softif_vlan near use batman-adv: Place kref_get for nc_node near use batman-adv: Place kref_get for nc_path near use batman-adv: Place kref_get for tvlv_container near use batman-adv: Place kref_get for tvlv_handler near use batman-adv: Keep batadv netdev when hardif disappears batman-adv: Allow to disable debugfs support batman-adv: Remove unused function batadv_hash_delete batman-adv: Move batadv_sum_counter to soft-interface.c batman-adv: Remove unused batadv_icmp_user_cmd_type batman-adv: Remove needless init of variables on stack batman-adv: Use proper name for fragments list head batman-adv: Use proper name for gateway list head batman-adv: Use octal permissions instead of macros batman-adv: Avoid precedence issues in macros
kbuild test robot (1): batman-adv: fix boolreturn.cocci warnings
stephen hemminger (1): batman: make netlink attributes const
-----------------------------------------------------------------------