The annotated tag, batadv-next-for-davem-20161119 has been created at 9ba27522f3b2a2c55cdbdda9aceed7f438746505 (tag) tagging 9b4aec647a92a2464337db10507348aecf0f0fd7 (commit) replaces v4.8 tagged by Simon Wunderlich on Sat Nov 19 14:31:20 2016 +0100
- Shortlog ------------------------------------------------------------ This feature patchset includes the following changes:
- 6 patches adding functionality to detect a WiFi interface under other virtual interfaces, like VLANs. They introduce a cache for the detected the WiFi configuration to avoid RTNL locking in critical sections. Patches have been prepared by Marek Lindner and Sven Eckelmann
- Enable automatic module loading for genl requests, by Sven Eckelmann
- Fix a potential race condition on interface removal. This is not happening very often in practice, but requires bigger changes to fix, so we are sending this to net-next. By Linus Luessing
Andrew Lunn (5): batman-adv: Handle parent interfaces in a different netns batman-adv: Suppress debugfs entries for netns's batman-adv: add B.A.T.M.A.N. IV bat_gw_dump implementations batman-adv: add B.A.T.M.A.N. Dump BLA claims via netlink batman-adv: Indicate netlink socket can be used with netns.
Antonio Quartulli (5): batman-adv: make the GW selection class algorithm specific batman-adv: make GW election code protocol specific batman-adv: B.A.T.M.A.N. V - implement GW selection logic batman-adv: disable sysfs knobs when GW-mode is not implemented batman-adv: remove unsed argument from batadv_dbg_arp() function
David S. Miller (2): Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net Merge tag 'batadv-next-for-davem-20161027' of git://git.open-mesh.org/linux-merge
Jarod Wilson (1): net: use core MTU range checking in misc drivers
Johannes Berg (3): genetlink: no longer support using static family IDs genetlink: statically initialize families genetlink: mark families as __ro_after_init
Linus Lüssing (11): batman-adv: Remove unused primary_if and bat_priv variables batman-adv: Introduce forward packet creation helper batman-adv: Use bitwise instead of arithmetic operator for flags batman-adv: fix batadv_forw_packet kerneldoc for list attribute batman-adv: Allow selecting BATMAN V if CFG80211 is not built batman-adv: Add wrapper for ARP reply creation batman-adv: Remove unnecessary lockdep in batadv_mcast_mla_list_free batman-adv: Remove unused skb_reset_mac_header() batman-adv: Use own timer for multicast TT and TVLV updates batman-adv: Simple (re)broadcast avoidance batman-adv: fix rare race conditions on interface removal
Marek Lindner (3): batman-adv: refactor wifi interface detection batman-adv: additional checks for virtual interfaces on top of WiFi batman-adv: retrieve B.A.T.M.A.N. V WiFi neighbor stats from real interface
Markus Elfring (1): batman-adv: Less function calls in batadv_is_ap_isolated() after error detection
Markus Pargmann (1): batman-adv: iv_ogm, Reduce code duplication
Masahiro Yamada (1): treewide: remove redundant #include <linux/kconfig.h>
Matthias Schiffer (6): batman-adv: netlink: add routing_algo query batman-adv: netlink: hardif query batman-adv: netlink: add translation table query batman-adv: netlink: add originator and neighbor table queries batman-adv: add B.A.T.M.A.N. IV bat_{orig, neigh}_dump implementations batman-adv: add B.A.T.M.A.N. V bat_{orig, neigh}_dump implementations
Simon Wunderlich (3): batman-adv: Start new development cycle batman-adv: add backbone table netlink support batman-adv: Start new development cycle
Sven Eckelmann (57): batman-adv: Document optional batadv_algo_ops batman-adv: Define module rtnl link name batman-adv: Modify mesh_iface outside sysfs context batman-adv: Revert "postpone sysfs removal when unregistering" batman-adv: Avoid sysfs name collision for netns moves batman-adv: use kmem_cache for translation table batman-adv: Remove orig_node reference handling from send_skb_unicast batman-adv: Fix consistency of update route messages batman-adv: Provide TTVN in the mesh_info netlink msg batman-adv: netlink: add gateway table queries batman-adv: add B.A.T.M.A.N. V bat_gw_dump implementations batman-adv: Provide bla group in the mesh_info netlink msg batman-adv: Place kref_get for orig_node_vlan near use batman-adv: Place kref_get for orig_ifinfo near use batman-adv: Place kref_get for tt_orig_list_entry near use batman-adv: Place kref_get for neigh_ifinfo near use batman-adv: Place kref_get for neigh_node near use batman-adv: Place kref_get for orig_node near use batman-adv: Place kref_get for tt_local_entry near use batman-adv: Place kref_get for tt_common near use batman-adv: Place kref_get for bla_claim near use batman-adv: Place kref_get for bla_backbone_gw near use batman-adv: Place kref_get for dat_entry near use batman-adv: Place kref_get for gw_node near use batman-adv: Place kref_get for hard_iface near use batman-adv: Place kref_get for softif_vlan near use batman-adv: Place kref_get for nc_node near use batman-adv: Place kref_get for nc_path near use batman-adv: Place kref_get for tvlv_container near use batman-adv: Place kref_get for tvlv_handler near use batman-adv: Keep batadv netdev when hardif disappears batman-adv: Allow to disable debugfs support batman-adv: Remove unused function batadv_hash_delete batman-adv: Move batadv_sum_counter to soft-interface.c batman-adv: Remove unused batadv_icmp_user_cmd_type batman-adv: Remove needless init of variables on stack batman-adv: Use proper name for fragments list head batman-adv: Use proper name for gateway list head batman-adv: Use octal permissions instead of macros batman-adv: Avoid precedence issues in macros batman-adv: Revert "use core MTU range checking in misc drivers" batman-adv: Introduce missing headers for genetlink restructure batman-adv: Mark batadv_netlink_ops as const batman-adv: Close two alignment holes in batadv_hard_iface batman-adv: use consume_skb for non-dropped packets batman-adv: Count all non-success TX packets as dropped batman-adv: Consume skb in batadv_frag_send_packet batman-adv: Consume skb in batadv_send_skb_to_orig batman-adv: Consume skb in receive handlers batman-adv: Remove dev_queue_xmit return code exception batman-adv: Disallow mcast src address for data frames batman-adv: Disallow zero and mcast src address for mgmt frames batman-adv: Reject unicast packet with zero/mcast dst address batman-adv: Return non-const ptr in batadv_getlink_net batman-adv: Cache the type of wifi device for each hardif batman-adv: Update wifi flags on upper link change batman-adv: Add module alias for batadv netlink family
kbuild test robot (1): batman-adv: fix boolreturn.cocci warnings
stephen hemminger (1): batman: make netlink attributes const
-----------------------------------------------------------------------