The following commit has been merged in the next branch: commit 04d38492d6a3576530645621919a3bc73ec1387e Author: Sven Eckelmann sven@narfation.org Date: Sat May 12 13:48:59 2012 +0200
batman-adv: Prefix compat static inline functions with batadv_
All non-static symbols of batman-adv were prefixed with batadv_ to avoid collisions with other symbols of the kernel. Other symbols of batman-adv should use the same prefix to keep the naming scheme consistent.
Signed-off-by: Sven Eckelmann sven@narfation.org
diff --git a/compat.h b/compat.h index 7347890..d58ba17 100644 --- a/compat.h +++ b/compat.h @@ -113,12 +113,12 @@ struct kernel_param_ops { __compat_get_param_##name, arg, \ __same_type((arg), bool *), perm)
-static inline int __param_set_copystring(const char *val, - const struct kernel_param *kp) +static inline int batadv_param_set_copystring(const char *val, + const struct kernel_param *kp) { return param_set_copystring(val, (struct kernel_param *)kp); } -#define param_set_copystring __param_set_copystring +#define param_set_copystring batadv_param_set_copystring
/* hack for dev->addr_assign_type &= ~NET_ADDR_RANDOM; */ #define addr_assign_type ifindex