The following commit has been merged in the linux branch: commit 1b59dd511b9a36d4be3c01d7c7024aeec36dc651 Author: Jens Axboe jens.axboe@oracle.com Date: Tue Oct 6 20:19:02 2009 +0200
block: use proper BLK_RW_ASYNC in blk_queue_start_tag()
Makes it easier to read than the 0.
Signed-off-by: Jens Axboe jens.axboe@oracle.com
diff --git a/block/blk-tag.c b/block/blk-tag.c index 2e5cfeb..6b0f52c 100644 --- a/block/blk-tag.c +++ b/block/blk-tag.c @@ -359,7 +359,7 @@ int blk_queue_start_tag(struct request_queue *q, struct request *rq) max_depth -= 2; if (!max_depth) max_depth = 1; - if (q->in_flight[0] > max_depth) + if (q->in_flight[BLK_RW_ASYNC] > max_depth) return 1; }