The annotated tag, batman-adv-for-davem has been updated to ad1c8b0817e002e9901b44be822a90251713fadb (tag) from 9cff54f5faa705b3a85107b135c52581d592e940 (which is now obsolete) tagging 3ad345e2521ef41500cc0890a717656b975c4321 (commit) replaces v3.4-rc4 tagged by Antonio Quartulli on Sun Apr 29 10:50:34 2012 +0200
- Shortlog ------------------------------------------------------------ Included changes:
* a new feature has been introduced: D.A.T. (Distributed ARP Table). It is a mechanism based on DHT theory that creates a distributed (mesh network wide) ARP cache in order to speed up ARP resolutions in sparse wireless mesh networks. * in order to satisfy DAT requirements a new unicast packet type, namely UNICAST_4ADDR, has been introduced. Backward compatibility has been kept: not updated nodes will simply drop the packet and ignore DAT mechanism. * minor fixes and cleanups * minor routing protocol API cleanups
Antonio Quartulli (16): batman-adv: clean up Kconfig batman-adv: use ETH_ALEN instead of hardcoded numeric constants batman-adv: convert the tt_crc to network order batman-adv: remove duplicated line in comment batman-adv: use ETH_HLEN instead of sizeof(struct ethhdr) batman-adv: print OGM seq numbers as unsigned int batman-adv: skip the window protection test when the originator has no neighbours batman-adv: add UNICAST_4ADDR packet type batman-adv: add a new log level for DAT debugging batman-adv: add biggest_unsigned_int(x) macro batman-adv: Distributed ARP Table - create DHT helper functions batman-adv: Distributed ARP Table - add ARP parsing functions batman-adv: Distributed ARP Table - add snooping functions for ARP messages batman-adv: Distributed ARP Table - increase default soft_iface ARP table timeout batman-adv: Distributed ARP Table - add compile option batman-adv: fix wrong dhcp option list browsing
Eric Dumazet (1): net: cleanup unsigned to unsigned int
Marek Lindner (15): batman-adv: encourage batman to take shorter routes by changing the default hop penalty batman-adv: move ogm initialization into the proper function batman-adv: refactoring API: find generalized name for bat_ogm_init callback batman-adv: randomize initial seqno to avoid collision batman-adv: add iface_disable() callback to routing API batman-adv: handle routing code initialization properly batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN batman-adv: mark existing ogm variables as batman iv batman-adv: introduce is_single_hop_neigh variable to increase readability batman-adv: introduce packet type handler array for incoming packets batman-adv: register batman ogm receive function during protocol init batman-adv: rename last_valid to last_seen batman-adv: replace HZ calculations with jiffies_to_msecs() batman-adv: split neigh_new function into generic and batman iv specific parts
Simon Wunderlich (10): batman-adv: remove old bridge loop avoidance code batman-adv: add basic bridge loop avoidance code batman-adv: make bridge loop avoidance switchable batman-adv: export claim tables through debugfs batman-adv: allow multiple entries in tt_global_entries batman-adv: don't let backbone gateways exchange tt entries batman-adv: add broadcast duplicate check batman-adv: drop STP over batman batman-adv: form groups in the bridge loop avoidance batman-adv: add bridge loop avoidance compile option
Sven Eckelmann (2): batman-adv: Replace bitarray operations with bitmap batman-adv: Remove declaration of only locally used functions
-----------------------------------------------------------------------