The annotated tag, batman-adv-for-davem has been updated to f575c93b2106a4dbd0da657ae7abf019df2d421e (tag) from 63c4ffbae4ae003eb3920a3da115501ea20f49dc (which is now obsolete) tagging 1b0c84cbf9a744307c80a83dcdd3023f4d65f894 (commit) replaces v3.4-rc5 tagged by Antonio Quartulli on Sat May 12 14:28:22 2012 +0200
- Shortlog ------------------------------------------------------------ Included changes:
* an improvement to avoid to linearise the whole received packet when not needed * an improvement for client traffic rerouting after roaming * a fix for the local translation table state-machine * minor cleanups and fixes
Antonio Quartulli (13): batman-adv: clean up Kconfig batman-adv: use ETH_ALEN instead of hardcoded numeric constants batman-adv: convert the tt_crc to network order batman-adv: remove duplicated line in comment batman-adv: use ETH_HLEN instead of sizeof(struct ethhdr) batman-adv: print OGM seq numbers as unsigned int batman-adv: skip the window protection test when the originator has no neighbours batman-adv: fix wrong dhcp option list browsing batman-adv: update copyright years batman-adv: add contributor name batman-adv: avoid skb_linearise() if not needed batman-adv: improve unicast packet (re)routing batman-adv: unset the TT_CLIENT_PENDING flag if the new local entry already exists
Eric Dumazet (1): net: cleanup unsigned to unsigned int
Linus Luessing (1): batman-adv: Adding hard_iface specific sysfs wrapper macros for UINT
Marek Lindner (22): batman-adv: encourage batman to take shorter routes by changing the default hop penalty batman-adv: move ogm initialization into the proper function batman-adv: refactoring API: find generalized name for bat_ogm_init callback batman-adv: randomize initial seqno to avoid collision batman-adv: add iface_disable() callback to routing API batman-adv: handle routing code initialization properly batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN batman-adv: mark existing ogm variables as batman iv batman-adv: introduce is_single_hop_neigh variable to increase readability batman-adv: introduce packet type handler array for incoming packets batman-adv: register batman ogm receive function during protocol init batman-adv: rename last_valid to last_seen batman-adv: replace HZ calculations with jiffies_to_msecs() batman-adv: split neigh_new function into generic and batman iv specific parts batman-adv: ignore protocol packets if the interface did not enable this protocol batman-adv: refactoring API: find generalized name for bat_ogm_update_mac callback batman-adv: rename sysfs macros to reflect the soft-interface dependency batman-adv: avoid temporary routing loops by being strict on forwarded OGMs batman-adv: fix checkpatch string complaint batman-adv: prepare lq_update_lock to be shared among different protocols batman-adv: refactor window_protected to avoid unnecessary return statement
Simon Wunderlich (10): batman-adv: remove old bridge loop avoidance code batman-adv: add basic bridge loop avoidance code batman-adv: make bridge loop avoidance switchable batman-adv: export claim tables through debugfs batman-adv: allow multiple entries in tt_global_entries batman-adv: don't let backbone gateways exchange tt entries batman-adv: add broadcast duplicate check batman-adv: drop STP over batman batman-adv: form groups in the bridge loop avoidance batman-adv: add bridge loop avoidance compile option
Sven Eckelmann (4): batman-adv: Replace bitarray operations with bitmap batman-adv: Remove declaration of only locally used functions batman-adv: use shorter pr_warn instead of pr_warning batman-adv: Start new development cycle
-----------------------------------------------------------------------