The branch, ecsv/flowdissector-header-rename has been created at b7a18192f75ad7d389e697b566aba3e6c3c2743f (commit)
- Shortlog ------------------------------------------------------------ commit b7a18192f75ad7d389e697b566aba3e6c3c2743f Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Mon Nov 27 13:33:41 2017 +0100
flow_dissector: Parse batman-adv unicast headers
The batman-adv unicast packets contain a full layer 2 frame in encapsulated form. The flow dissector must therefore be able to parse the batman-adv unicast header to reach the layer 2+3 information.
+--------------------+ | ip(v6)hdr | +--------------------+ | inner ethhdr | +--------------------+ | batadv unicast hdr | +--------------------+ | outer ethhdr | +--------------------+
The obtained information from the upper layer can then be used by RPS to schedule the processing on separate cores. This allows better distribution of multiple flows from the same neighbor to different cores.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 3af0bc37cb673231648915e831d11d47029d3aea Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:39:48 2017 +0100
batman-adv: Convert packet.h to uapi header
The header file is used by different userspace programs to inject packets or to decode sniffed packets. It should therefore be available to them as userspace header.
Also other components in the kernel (like the flow dissector) require access to the packet definitions to be able to decode ETH_P_BATMAN ethernet packets.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 23029d2a26700d6642c77e05a10b5c432b8bee24 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:17:28 2017 +0100
batman-adv: Remove usage of BIT(x) in packet.h
The BIT(x) macro is no longer available for uapi headers because it is defined outside of it (linux/bitops.h). The use of it must therefore be avoided and replaced by an appropriate other representation.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit bcc795fdbebce9e5b1794a82b19c566721efc656 Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 11:39:29 2017 +0100
batman-adv: Let packet.h include its headers directly
The headers used by packet.h should also be included by it directly. main.h is currently dealing with it in batman-adv, but this will no longer work when this header is moved to include/uapi/linux/.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit fb7761283afd1ee5ec667bb6ba892a24b747da1a Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:31:51 2017 +0100
batman-adv: Rename batman-adv.h to batadv_genl.h
This file contains the relevant information to let userspace communicate with batman-adv over generic netlink. The relevant genl enums for the attributes and commands have the prefix batadv_genl. Renaming this file to this name therefore represents the content better and avoids confusion with the file which will contain the packet format definitions.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
commit 8b72bd899005554441aa7376dbf6ff2eb8c7532f Author: Sven Eckelmann sven.eckelmann@openmesh.com Date: Tue Dec 5 14:22:16 2017 +0100
batman-adv: Change nl references to genl
The batman-adv netlink functionality is actually not pure netlink but is using NETLINK_GENERIC and related API. The code should therefore also use this "genl" instead of "nl" to make this more clear.
Signed-off-by: Sven Eckelmann sven.eckelmann@openmesh.com
-----------------------------------------------------------------------