The following commit has been merged in the master branch:
commit 0118a62f7244a016207a0990b00c622ac2ac693f
Author: Sven Eckelmann <sven(a)narfation.org>
Date: Sat May 12 18:33:58 2012 +0200
batman-adv: Prefix hash local static functions with batadv_
All non-static symbols of batman-adv were prefixed with batadv_ to avoid
collisions with other symbols of the kernel. Other symbols of batman-adv
should use the same prefix to keep the naming scheme consistent.
Signed-off-by: Sven Eckelmann <sven(a)narfation.org>
diff --git a/hash.c b/hash.c
index 42466c2..4ab46d4 100644
--- a/hash.c
+++ b/hash.c
@@ -21,7 +21,7 @@
#include "hash.h"
/* clears the hash */
-static void hash_init(struct hashtable_t *hash)
+static void batadv_hash_init(struct hashtable_t *hash)
{
uint32_t i;
@@ -58,7 +58,7 @@ struct hashtable_t *batadv_hash_new(uint32_t size)
goto free_table;
hash->size = size;
- hash_init(hash);
+ batadv_hash_init(hash);
return hash;
free_table:
--
batman-adv
The following commit has been merged in the master branch:
commit a80c651e255459af251995ec05f817b3dcdc5a6a
Author: Sven Eckelmann <sven(a)narfation.org>
Date: Sat May 12 18:33:56 2012 +0200
batman-adv: Prefix gateway_common local static functions with batadv_
All non-static symbols of batman-adv were prefixed with batadv_ to avoid
collisions with other symbols of the kernel. Other symbols of batman-adv
should use the same prefix to keep the naming scheme consistent.
Signed-off-by: Sven Eckelmann <sven(a)narfation.org>
diff --git a/gateway_common.c b/gateway_common.c
index 3700562..6edf37f 100644
--- a/gateway_common.c
+++ b/gateway_common.c
@@ -22,7 +22,7 @@
#include "gateway_client.h"
/* calculates the gateway class from kbit */
-static void kbit_to_gw_bandwidth(int down, int up, long *gw_srv_class)
+static void batadv_kbit_to_gw_bandwidth(int down, int up, long *gw_srv_class)
{
int mdown = 0, tdown, tup, difference;
uint8_t sbit, part;
@@ -73,8 +73,8 @@ void batadv_gw_bandwidth_to_kbit(uint8_t gw_srv_class, int *down, int *up)
*up = ((upart + 1) * (*down)) / 8;
}
-static bool parse_gw_bandwidth(struct net_device *net_dev, char *buff,
- int *up, int *down)
+static bool batadv_parse_gw_bandwidth(struct net_device *net_dev, char *buff,
+ int *up, int *down)
{
int ret, multi = 1;
char *slash_ptr, *tmp_ptr;
@@ -142,7 +142,7 @@ ssize_t batadv_gw_bandwidth_set(struct net_device *net_dev, char *buff,
int up = 0, down = 0;
bool ret;
- ret = parse_gw_bandwidth(net_dev, buff, &up, &down);
+ ret = batadv_parse_gw_bandwidth(net_dev, buff, &up, &down);
if (!ret)
goto end;
@@ -152,7 +152,7 @@ ssize_t batadv_gw_bandwidth_set(struct net_device *net_dev, char *buff,
if (!up)
up = down / 5;
- kbit_to_gw_bandwidth(down, up, &gw_bandwidth_tmp);
+ batadv_kbit_to_gw_bandwidth(down, up, &gw_bandwidth_tmp);
/* the gw bandwidth we guessed above might not match the given
* speeds, hence we need to calculate it back to show the number
--
batman-adv
The following commit has been merged in the master branch:
commit 04d38492d6a3576530645621919a3bc73ec1387e
Author: Sven Eckelmann <sven(a)narfation.org>
Date: Sat May 12 13:48:59 2012 +0200
batman-adv: Prefix compat static inline functions with batadv_
All non-static symbols of batman-adv were prefixed with batadv_ to avoid
collisions with other symbols of the kernel. Other symbols of batman-adv
should use the same prefix to keep the naming scheme consistent.
Signed-off-by: Sven Eckelmann <sven(a)narfation.org>
diff --git a/compat.h b/compat.h
index 7347890..d58ba17 100644
--- a/compat.h
+++ b/compat.h
@@ -113,12 +113,12 @@ struct kernel_param_ops {
__compat_get_param_##name, arg, \
__same_type((arg), bool *), perm)
-static inline int __param_set_copystring(const char *val,
- const struct kernel_param *kp)
+static inline int batadv_param_set_copystring(const char *val,
+ const struct kernel_param *kp)
{
return param_set_copystring(val, (struct kernel_param *)kp);
}
-#define param_set_copystring __param_set_copystring
+#define param_set_copystring batadv_param_set_copystring
/* hack for dev->addr_assign_type &= ~NET_ADDR_RANDOM; */
#define addr_assign_type ifindex
--
batman-adv