[B.A.T.M.A.N.] Problem with DHCP on batman-adv V

Antonio Quartulli a at unstable.cc
Thu May 12 10:57:49 CEST 2016


On Thu, May 12, 2016 at 07:05:20AM +0200, Sven Eckelmann wrote:
> On Wednesday 11 May 2016 18:58:48 Alvaro Antelo wrote:
> > Hi everyone,
> > 
> > I am testing batman-adv V5 from the development feed on Chaos Calmer
> > and so far everything is working except for DHCP IPv4, only static
> > addresses.
> > In the same setup wich involves bridges connected to bat0 interfaces,
> > if I change only the routing algorithm to batman-adv IV, DHCP works
> > fine.
> > 
> > Is it a expected behaviour?
> 
> Afaik there is no working gateway selection logic in B.A.T.M.A.N. V. At least 
> Antonio works on some patches for this:
> 
> https://patchwork.open-mesh.org/patch/16139/
> https://patchwork.open-mesh.org/patch/16140/
> https://patchwork.open-mesh.org/patch/16141/
> https://patchwork.open-mesh.org/patch/16142/
> https://patchwork.open-mesh.org/patch/16143/
> 
> This includes splitting up the logic and use the metrics for each routing 
> algorithm. But I think he can tell you more about now works (or doesn't) and 
> what will work after his patchset is applied.

Sven was right. In our current code, the GW selection logic doesn't work when
using B.A.T.M.A.N. V. We are working on it.

Maybe you could try applying the patches suggested by Sven and let us know if it
works for you ?

In the meanwhile you can just disable GW mode (batctl gw off).

Cheers,



-- 
Antonio Quartulli
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.open-mesh.org/pipermail/b.a.t.m.a.n/attachments/20160512/83cd4a4e/attachment-0001.sig>


More information about the B.A.T.M.A.N mailing list