[B.A.T.M.A.N.] [PATCH 06/10] alfred-gpsd: Fix altitute verification check

Sven Eckelmann sven at narfation.org
Sat May 24 13:44:11 CEST 2014


Signed-off-by: Sven Eckelmann <sven at narfation.org>

---
 gpsd/alfred-gpsd.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gpsd/alfred-gpsd.c b/gpsd/alfred-gpsd.c
index ef20f28..089f2af 100644
--- a/gpsd/alfred-gpsd.c
+++ b/gpsd/alfred-gpsd.c
@@ -370,7 +370,7 @@ static void gpsd_parse_location(struct globals *globals,
 		exit(EXIT_FAILURE);
 	}
 
-	if ((alt < -1000) || (lon > 9000)) {
+	if ((alt < -1000) || (alt > 9000)) {
 		/* No support for aircraft or submarines! */
 		printf("Invalid altitude\n");
 		gpsd_usage();
-- 
2.0.0.rc2



More information about the B.A.T.M.A.N mailing list