[B.A.T.M.A.N.] BW degradation on p2p links?

Marek Lindner lindner_marek at yahoo.de
Mon Mar 26 16:47:17 CEST 2012


Hi,

> i'm participating in the development of a wireless mesh network in
> Delta de Tigre, near Buenos Aires, Argentina.
> Landscape is absolutely flat, with dense forest 15-20mts tall. Nodes
> are being installed along the river, 50 - 150mts apart, with clear LOS
> at ground level.
> I collaborated with Nico Echaniz last month, bulding another community
> network in Cordoba, and given the success, I decided to start one more
> here. I'm also really thankful with Elektra, for recommending the
> tl-m3220 to Nico!
> We chose batman over olsr, in part because of avahi stuff, but also to
> have a real-world implementation and thus collaborate in testing /
> debugging :) So far, there are  only 4 working nodes, but luckily I'm
> already facing unexpected behaviour.
> 
> I'm sorry for the long email, it's mostly terminal logs.
> In short, iperf between two neighbouring nodes reports >20mbps, yet
> running the same iperf between nodes separated by one hop reports
> inexplicably low <5mbps.
>
> [..]
>
> Any ideas, thoughts, pointers? Any additional info needed?

welcome on the list!
I admit not having dived into all the details of your mail - the bigger part 
of the batman team is sitting in Athens at the moment (see battlemesh.org). 
The best next step is to find out whether this performance issue is a batman-
adv or a wifi driver problem. May I suggest you remove batman-adv and repeat 
the same test using static routing ? If you still see the problem it is the 
wifi that is not working otherwise we have to fix batman-adv.

Regards,
Marek



More information about the B.A.T.M.A.N mailing list