On Sunday 28 December 2008 15:24:57 Marek Lindner wrote:
> Afterwards the development branch should change the RELEASE_VERSION to
> the upcoming version number and the EXTRA_VERSION to a string which
> informs the user that it is "unstable" and in development. This could be
> for example "-dev", "-pre-alpha", "-beta" or
I like your patch a lot. It could solve a nasty little problem that always
tends to be forgotten. :-)
Yes, Simon told me about that :D
Unfortunately, our compile farm which feeds the package repository
the SOURCE_VERSION from batman.h to generate the package name. Unless we
rewrite the compile scripts to extract both defines we can't apply your
patch as-is. This rewrite is not as painless as it could be. Certainly, at
some point we want to touch the scripts to optimize the speed but that
wasn't on our agenda right now.
Didn't know that but that makes patch of
course useless. I liked the idea to
have a version which marks the next release and the extra part which marks the
actual status of the next release. This is only one way to express this.
Do you see alternatives which allow us to reuse the existing compile
and have the functionality you implemented ?
We could also assume that the version
string has a specific format. A version
number (RELEASE_VERSION part thing in my last patch) which has a postfix
seperated by a dash. If that dash is found in the version string then we have
a postfix and we are currently in a unstable version.
Don't know if this makes really sense for B.A.T.M.A.N. but the patch for that