Linus Lüssing wrote:
actually, there were two reasons for renaming that I guess. One was out of "laziness" and I wanted to keep the number of parameters of a BAT_ATTR_* macro as less as possible. Otherwise I'd have to have another field, one for stating the name in sysfs and one for the name in bat_priv.
I then was wondering why the names between sysfs and bat_priv shouldn't be the same instead (or +_enabled for switch/bool attributes). I could have renamed the part in bat_priv to aggregate_ogms_enabled but found that a little long (the same for fragmentation_enabled). Or the _enabled parts could be removed in bat_priv, but making it less obvious, what kind of values they might take.
So I thought that just aggregation might be a good trade-off. And that anyone who might be confused by the names, not knowing what they might be used for, should use batctl instead (and its manpage for explanations).
Or would anybody prefer another solution (of the ones described above)?
Please don't change the sysfs names.
And document all your sysfs files for sysfs-class-net-mesh and sysfs-class-net-batman-adv in linux-merge.git
Still missing stuff are: * fragmentation (@Andreas - your part) * gw_mode (can be documented later) * hop_penalty * num_bcasts * log_level