On Tuesday 15 May 2012 17:54:58 Marek Lindner wrote:
On Sunday, May 13, 2012 00:33:52 Sven Eckelmann wrote:
All non-static symbols of batman-adv were prefixed with batadv_ to avoid collisions with other symbols of the kernel. Other symbols of batman-adv should use the same prefix to keep the naming scheme consistent.
Signed-off-by: Sven Eckelmann sven@narfation.org
bat_sysfs.c | 250
++++++++++++++++++++++++++++++++--------------------------- 1 file changed, 135 insertions(+), 115 deletions(-)
Applied in revision 98881e4.
Thanks, Marek
But you only committed it partially. There are parts missing
Just to show what is missing:
@@ -123,8 +123,9 @@ ssize_t batadv_show_##_name(struct kobject *kobj, \
#define BAT_ATTR_HIF_STORE_UINT(_name, _min, _max, _post_func) \ -ssize_t store_##_name(struct kobject *kobj, struct attribute *attr, \ - char *buff, size_t count) \ +ssize_t batadv_store_##_name(struct kobject *kobj, \ + struct attribute *attr, char *buff, \ + size_t count) \ { \ struct net_device *net_dev = batadv_kobj_to_netdev(kobj); \ struct hard_iface *hard_iface; \ @@ -142,8 +143,8 @@ ssize_t store_##_name(struct kobject *kobj, struct attribute *attr, \ }
#define BAT_ATTR_HIF_SHOW_UINT(_name) \ -ssize_t show_##_name(struct kobject *kobj, \ - struct attribute *attr, char *buff) \ +ssize_t batadv_show_##_name(struct kobject *kobj, \ + struct attribute *attr, char *buff) \ { \ struct net_device *net_dev = batadv_kobj_to_netdev(kobj); \ struct hard_iface *hard_iface; \